Introduction





This document provides additional information if you are using OfficePower for Windows with Microsoft Office 97, or with Windows NT Workstation 4, or both. It should be read in conjunction with the OfficePower for Windows Installation Guide and the OfficePower for Windows manual, but replaces the information provided in the file c:\op4w\intkit\readme.txt supplied with the OfficePower for Windows software.





Using Microsoft Office 97 with OfficePower/Xtra





Microsoft Office 97 introduced new file formats for Word Documents, Excel Workbooks, and the other objects that can be produced using Office applications. These file formats are generally incompatible with earlier versions of the Office applications, and can cause serious interworking problems in an environment where all users do not have Office 97. For example, a document produced using Word for Windows 97 and sent (by electronic mail, or merely by handing over a diskette) to a user of Word for Windows 6.0 would be unreadable by the recipient.





At OfficePower/Xtra Version 3, the same would be true of a document produced in Word for Windows 97 and sent to a user of a text terminal – OfficePower can recognise the Word 97 document, but cannot convert it for the text terminal user.





These problems can be minimised, and documents (or workbooks, or other Office objects) can be exchanged between users of Office 97, users of earlier versions of Microsoft Office, and text terminal users, by running the Office 97 applications in “compatibility” or  “transition” mode. In this case, the Office 97 applications store their files in a format compatible with Office 4.2 or Office 95 applications, instead of in their “native” formats. It is strongly recommended that you use Office 97 only in this mode, unless ALL your PC users have Office 97 (all earlier versions having been replaced) and there is NO requirement to send files to users of text terminals.





To configure Microsoft Office 97 applications for “compatibility” mode, set the appropriate Options in the applications as follows:





Word 97	Select Options from the Tools menu. Select the Save tab. Set the entry for Save Word files as to Word 6.0/95 (*.doc)





Excel 97	Select Options from the Tools menu. Select the Transition tab. Set the entry for Save Excel files as to Microsoft Excel 5.0/95 Workbook





PowerPoint 97	Select Options from the Tools menu. Select the Save tab. Set the entry for Save PowerPoint files as to Microsoft PowerPoint 4.0 Presentation





When you use Save As after setting the above options, you will be asked if you want to use the appropriate “compatibility” format. Click on the Use suggested format button, and then complete the Save As dialogue box as usual. This will save the file in a format suitable for users without access to Microsoft Office 97.





The OfficePower integration kit will also make use of the “compatibility” formats you have chosen. Thus, if you create a new document in Word for Windows 97, and then Store or Send it without first using Save As, the document stored on the server or attached to your mail item will be in the format you selected using Tools:Options as described above. You will NOT be asked to confirm the choice of format when files are saved by the integration kit in these circumstances.





However, there are a couple of additional considerations when using the above technique in Office 97. Firstly, in the original release of Word 97, saving a document as Word 6.0/95 format did not do what you asked – it actually saved the document in Rich Text Format (RTF). This format can be used as a “compatibility” format with OfficePower and with earlier versions of Office, but it can be disconcerting if you ask to save a file in .doc format and OfficePower then (correctly) describes it as .rtf. Microsoft corrected this problem in Office 97 Service Release 1, and it is strongly recommended you obtain (from Microsoft) and install this release.





Secondly, even with Service Release 1 installed, when Office applications save a file in one of the “compatibility” formats such as Word 6.0/95, they can still produce a file that is NOT readable by earlier versions of Office, or by OfficePower. Word documents making use of complex formatting or embedded graphics are particularly liable to this problem. 





If you wish to check that a Word 97 document is likely to be readable by a Word 6 or text terminal user, BEFORE you send it to them, a quick check can be carried out using WordPad. Having saved the document as Word 6./95 in Word 97, open it in WordPad – if the text of the document is readable in WordPad, it is likely to be readable by your intended recipient. If, instead, WordPad displays “gibberish”, it suggests that Word 97 has produced an incorrectly formatted file, and you will need to amend and simplify the document before it can be used by your target audience.





Finally, there can be some confusion over the version numbers used to describe the differing releases of Microsoft Office Applications – for example, the product now generally described as “Word 97” is also described (e.g. within the documents it produces!) as “Word 8”. OfficePower uses the latter form when describing the file type, with a similar procedure for Excel. Additionally, OfficePower groups together the formats produced prior to Office 97, so the descriptions used are:





Description used by OfficePower�
Application used to produce the file�
�
Word for Windows 6.0, 7.0�
Word for Windows 6, Word for Windows 95, or Word for Windows 97 (Word 6.0/95 format)�
�
Word for Windows 8�
Word for Windows 97 (native format)�
�
Excel 5.0-7.0�
Excel 5, Excel 95, or Excel 97 (Excel 5.0/95 format)�
�
Excel Spreadsheet 8�
Excel 97 (native format)�
�






Installing the OfficePower Integration Kit in Microsoft Office 97





OfficePower for Windows (V2 or later) includes an Integration Kit that contains components for integration with Microsoft Word for Windows 97 and Microsoft Excel 97. (The integration kit also supports earlier versions of Microsoft Word and Excel as well as Corel WordPerfect – see the OfficePower for Windows Installation Guide for more details on these applications.) The integration kit adds an OfficePower menu to selected menu bars in Word or Excel.





For Word 97 and Excel 97, installing the integration kit components involves merely copying a file to the correct folder. You can carry out this process using Windows Explorer – find the correct integration kit component, use the RIGHT mouse button to drag it to the correct Office folder, and select Copy Here when prompted. (Note that the Word 97 and Excel 97 components are installed in different folders.)





Word 97	Copy the file c:\op4w\intkit\opwint8.dot to the STARTUP folder in the Microsoft Office folder structure. ��The STARTUP folder is normally ��c:\Program Files\Microsoft Office\Office\Startup. ��However, it may be different on your PC if you installed Office 97 in a different folder, or are using Profiles to support multiple users on the same PC. ��To check the correct name for the STARTUP folder on your PC, select Options from the Tools menu in Word 97, click on the File Locations tab and check the Startup entry in the list of file types. (If this entry is blank, you must set it before installing opwint8.dot.)





Excel 97	Copy the file C:\OP4W\INTKIT\OPWINT8.XLA to the XLSTART folder in the Microsoft Office folder structure. ��The XLSTART folder is normally ��c:\Program Files\Microsoft Office\Office\XLStart. ��However, it may be different on your PC if you installed Office 97 in a different folder – the XLSTART folder should be in the same Office folder as the STARTUP folder for Word 97.





When you next start Word or Excel after installing the integration kit components, the OfficePower menu will appear in the menu bar. In Excel, the OfficePower menu appears only in the Workbook menu bar. If you switch to another menu bar, such as the Chart menu bar (which is displayed while you are working on a Chart, rather than a Workbook), the OfficePower menu will disappear until you revert to the Workbook menu bar.





Using the STORE and SEND commands in the Integration Kit





The Store and Send File commands in the Integration Kit for Word 97 and Excel 97 now permit you to store or send a "New" file (i.e. one created using the File:New command and not yet saved on the PC disk) without requiring you to use File:Save first. 





Note that the "New" file will be closed as part of the Store or Send process, so you would not normally be able to continue work on that file after returning from Workspace. Should you need to retrieve a "New" file after initiating a Store or Send (for example, if you cancelled the process before its completion), click on the File menu. Now open the file opwstore.doc or opwstore.xls (if you used Store) or mailsend.doc or mailsend.xls (if you used Send File) from the list of recent files at the bottom of this menu. Use Save As on the File menu to save the file under another name before attempting a further Store or Send function.





Integration with Windows Explorer





OfficePower for Windows (V2 or later) includes integration with Windows Explorer. This comprises additional entries in the Send To section of the context menu displayed when you right click on a file in Explorer. A new Folder OfficePower for Windows appears in the Send To list – entries in this folder will let you store the selected file on the OfficePower server, or send it by OfficePower mail. These entries are installed automatically when OfficePower for Windows is installed.





On a single-user PC running Windows 95 or 98, the contents of the Send To list are stored in the folder c:\Windows\SendTo. You can customise the list by adding additional shortcuts to this folder, or its subfolders, or by moving or deleting existing entries – thus you can move or delete the OfficePower for Windows entries if you wish.





On a PC using Windows NT 4 Workstation (or using Windows 95 with User Profiles enabled) where the PC can be used by multiple users, the contents of the Send To list are part of the “desktop settings” which can be configured differently for each user. The Send To entries for OfficePower for Windows will only be installed in the Desktop of the user who installs OfficePower for Windows. If other users wish to use these entries, they can copy the settings to their desktop using Windows NT Explorer.





In Explorer, navigate to the folder c:\winnt\Profiles\user\SendTo where user is the name of the user who installed OfficePower for Windows. For example, if this was installed by the user Administrator, the folder is folder c:\winnt\Profiles\Administrator\SendTo. Now copy the OfficePower for Windows folder to the Send To folder for your user – for example c:\winnt\Profiles\Fred\SendTo. The OP4W integration entries will now be available in Explorer. You can further customise your personal  Send To list as described earlier.





Using OP4W Terminal and Windows NT 4.0 Workstation





When transferring a file to the PC for viewing or update by any PC application, OfficePower for Windows Terminal (WVT.EXE) uses the folder specified by the OP_BAK environment variable on the PC. In Windows 3.11, 95 or 98 such environment variables are set in the autoexec.bat file, and the OfficePower for Windows Installation Guide describes how to make the necessary changes to this file.


When using Windows NT 4.0, the OP_BAK environment variable is still used – but environment variables are no longer set in the autoexec.bat file. Instead, from the Start menu select Settings, then Control Panel. Double-click the System icon, then select the Environment tab. Now set OP_BAK as a User Variable. The value set must be the name of an existing folder to hold files fetched from the server by OP4W Terminal – for example c:\myfiles\temp. 


See the Help supplied with Windows NT 4.0 Workstation for more details on this procedure.





Using 32-bit applications and Windows NT 4.0 Workstation





Microsoft Office 97, and several other “32-bit” applications, are normally installed by default in a folder with a “long file name” which includes space characters – in the case of Office 97 the default folder is c:\Program Files\Microsoft Office. Such folder names can cause a number of problems in the interaction with other applications, including OfficePower for Windows, under Windows NT 4.0 Workstation. Note that such folder names are NOT generally a problem under Windows 95 or Windows 98.





Considering specifically Microsoft Office 97 under Windows NT 4.0 Workstation, if the default folder shown above is used, OfficePower will not be able to invoke these applications to update or view files, unless the application was already running at the time. If you have not yet installed Office 97 on your NT system, you can avoid the problem by choosing folders with "DOS-compatible" names when installing the applications - e.g. install in c:\mso97 instead of c:\Program Files\Microsoft Office.





You are offered the option to change the location in which Office 97 is installed at an early stage in the installation process – click on the Browse button and select your preferred location, such as c:\mso97 instead of the default offered. This will ensure that the main Office 97 applications are installed in c:\mso97\office. However, if you are going to install Photo Editor, this is normally installed in c:\Program Files\Common Files\Microsoft Shared\PhotEd – you should change this to, for example, c:\mso97\shared\photoed separately.





Similar problems would occur with Microsoft Internet Explorer, which is commonly installed in c:\Program Files\Plus!\Microsoft Internet – try installing in c:\msie instead.





If you have already installed the applications in their default folders, it is possible to correct the resulting problem, without re-installing the affected applications, by amending certain entries in the registry of your PC. If the necessary entries are amended to specify the DOS-compatible alias of the full folder name, the applications can be used correctly with OfficePower without affecting their normal working. 





However, do NOT attempt to make such changes using the normally recommended technique using View/Options/File Types in Windows Explorer. Any attempt to edit the registry entries for Office 97 in Windows Explorer actually corrupts the entries, causing undesirable side effects every time you start the applications subsequently.





To simplify the process of making the necessary changes to the registry, a number of Registration Files are supplied with this document, which will make the change a simple “click on a file” process for Microsoft Office (including Photo Editor) and Microsoft Internet Explorer. 





Before you apply these changes, it is strongly recommended that you take a backup of your existing registry. If you are not certain how to do this, ask your system administrator for advice before you continue.





If you have installed Office 97 in its default location c:\Program Files\Microsoft Office, you should first confirm the correct alias for that folder name. This identifies the correct registration file to use, as described below.


At a Command Prompt, type �dir c:\progra~1\micros~1\office\winword.exe


If the size and date of the file winword.exe is displayed, the alias you require is c:\progra~1\micros~1 and you should use the registration file called office1.reg – continue at step 5.


If instead the response is File not found, type dir c:\progra~1\micros~2\office\winword.exe


If this finds winword.exe, the alias you require is c:\progra~1\micros~2 and you should use the registration file called office2.reg. 


Having identified the correct registration file to use, just select the file office1.reg or office2.reg as appropriate in Windows Explorer, and double click on the file. 


You will see a dialogue box reporting that Information … has been successfully entered into the registry – click on OK.





If you encounter any problems after using either of the above two registration files, you can reverse the changes in the Registry and revert to the “long” folder names by double clicking on the file office0.reg.





If you have installed Office 97 in a different folder, or if neither of the two aliases suggested above is correct, do NOT use the supplied registration files. Later in this document are instructions on how to produce your own registration files.





For Photo Editor, verify the alias by typing dir c:\progra~1\common~1\micros~1\photoed\photoed.exe �and use the registration file photoed1.reg – the file photoed0.reg will revert to “long” folder names.





For Microsoft Internet Explorer, verify the alias by typing dir c:\progra~1\plus!\micros~1\iexplore.exe �and use the registration file msie1.reg – the file msie0.reg will revert to “long” folder names.





If Microsoft Office 97, Photo Editor or Internet Explorer are installed in folders other than the defaults described above, or if you need to amend the Registry entries for other 32-bit applications, you can produce the necessary registration files using the following procedure. This assumes some familiarity with the Windows Registry Editor. 





Start the Registry Editor by selecting Run from the Start menu and entering the command regedit


Open the HKEY_CLASSES_ROOT branch and find the key for the file extension used by the application you wish to modify – for example, for Word for Windows 8, look for the key .doc. (Other extensions to consider include .rtf .xls .csv .ppt .mdb .htm .jpg)


Click on the key and note the Default value for that key – Word.Document.8 in the case of the .doc key


Locate the key with the name identified in step 3 – Word.Document.8 in this case


Under this key you will find a sub-key /shell/open/command, i.e. Word.Document.8 /shell/open/command in this case


Click on the word command in the left hand pane to select this key, and then click on Export Registry File in the File menu, giving the file a name such as winword0.reg


Exit from Registry Editor





The file you have produced should look something like this:





REGEDIT4





[HKEY_CLASSES_ROOT\Word.Document.8\shell\open\command]


@="\"C:\\Program Files\\Microsoft Office\\Office\\Winword.exe\" /n"





Edit this file using Notepad to replace the “long” components of the folder name with the correct aliases – in this case you might replace Program Files by PROGRA~1 and Microsoft Office by MICROS~1. Be very careful not to delete any of the special characters such as \and " in the existing string.


Save the amended file with a name such as winword1.reg





The modified file might look like this:





REGEDIT4





[HKEY_CLASSES_ROOT\Word.Document.8\shell\open\command]


@="\"C:\\PROGRA~1\\MICROS~1\\Office\\Winword.exe\" /n"





You can now use the second file (winword1.reg) to amend the registry value to use the alias, and the first (winword0.reg) to reset your registry to its original values.
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